Du bist nicht angemeldet. Der Zugriff auf einige Boards wurde daher deaktiviert.

#1 14. November 2017 16:09

brandy
Server-Pate
Registriert: 05. Juni 2011
Beiträge: 799
Webseite

[GELÖST] Iframe funktioniert bei genau einem Server nicht

Hallo!

Ich muss bei einem geerbten Projekt eine Seite via Iframe einbinden - ob gut ob schlecht, egal.

Die interessantere Frage wäre, ob man Iframeeinbindungen serverseitig verbieten kann?
Ich habe nämlich schon einige Seiten eingebunden, die auch super funktionierten, jedoch alle Seiten die auf einem gewissen Server liegen (Godaddy) lassen sich nicht einbinden!?

Ist so etwas möglich?

Vielen Dank!

Offline

#2 15. November 2017 21:13

Andynium
Moderator
Ort: Dohna / SN / Deutschland
Registriert: 13. September 2010
Beiträge: 6.991
Webseite

Re: [GELÖST] Iframe funktioniert bei genau einem Server nicht

Gibt's da Unterschiede bei den verfügbaren Browsern?

Könnte dies auch eine Security-Geschichte sein?

Siehe

https://de.wikipedia.org/wiki/Same-Origin-Policy

Offline

#3 15. November 2017 21:16

brandy
Server-Pate
Registriert: 05. Juni 2011
Beiträge: 799
Webseite

Re: [GELÖST] Iframe funktioniert bei genau einem Server nicht

Habe heute die Lösung gefunden!

Man muss in der .htaccess folgendes ändern:

Header set X-Frame-Options "SAMEORIGIN"

zu

Header set X-Frame-Options "ALLOW-FROM https://example.com/"

Offline

#4 15. November 2017 21:19

Andynium
Moderator
Ort: Dohna / SN / Deutschland
Registriert: 13. September 2010
Beiträge: 6.991
Webseite

Re: [GELÖST] Iframe funktioniert bei genau einem Server nicht

Na da hatte ich doch mal den Finger drauf wink ...

Offline