Du bist nicht angemeldet. Der Zugriff auf einige Boards wurde daher deaktiviert.

#1 12. November 2020 12:15

Andynium
Moderator
Ort: Dohna / SN / Deutschland
Registriert: 13. September 2010
Beiträge: 6.991
Webseite

[GELÖST] Pretty URLs aktivieren, mal wieder

Moinsen,

stehe irgendwie gerade auf der Leitung, komm nicht auf die Lösung. Werd halt alt. Oder bin halt einfach raus aus der Materie...

Standardinstallation 1.12.2, PHP 7, htaccess original, Hosting bei all-inkl.com, Seite funktioniert soweit

Mit den Einträgen

$config['url_rewriting'] = 'mod_rewrite';
$config['page_extension'] = '.html'; 

bekomme ich zwar Pretty URLs, beim Klicken der Links bekomme ich aber immer wieder den Content der Startseite. Obwohl in der URL-Zeile des Browsers die richtige (mod_rewritete) URL steht.

Hat jemand einen Hint für mich?

Offline

#2 12. November 2020 13:23

NaN
Moderator
Ort: Halle (Saale)
Registriert: 09. November 2010
Beiträge: 4.353

Re: [GELÖST] Pretty URLs aktivieren, mal wieder

Da kein 404 Fehler entsteht und Du immer auf der Startseite landest, heißt das, das CMS ignoriert den Pfad in der URL völlig. Es ist also so, als würdest Du die Seite ohne irgendwelche Parameter aufrufen. Das wiederum kann nur dann der Fall sein, wenn die Rewrite-Rule falsch ist.

htaccess original

Die original Rewrite-Rule lautet:

RewriteRule ^(.+)$ index.php?page=$1 [QSA]

Deine Seiten hören aber nicht auf "page" sondern auf "seite".
Wenn Du $config['query_var'] änderst, musst Du auch die .htaccess entsprechend anpassen.


Module: GBFilePicker, AdvancedContent
Sicherheit: Beispiel .htaccess-Datei
CMSms 1.12.2 unter PHP 7:
cmsms-1.12.2-php7.2-diff.tar.gz (nur die geänderten Dateien)
cmsms-1.12.3.zip (inoffiziell - komplett inkl. Installer)

Offline

#3 12. November 2020 13:53

Andynium
Moderator
Ort: Dohna / SN / Deutschland
Registriert: 13. September 2010
Beiträge: 6.991
Webseite

Re: [GELÖST] Pretty URLs aktivieren, mal wieder

NaN schrieb:

Deine Seiten hören aber nicht auf "page" sondern auf "seite".
Wenn Du $config['query_var'] änderst, musst Du auch die .htaccess entsprechend anpassen.

Ich wusste es, dass ich nur ein kleines Detail übersehen habe ops ops ops ...

Danke dir!!!

Offline