Du bist nicht angemeldet. Der Zugriff auf einige Boards wurde daher deaktiviert.

#1 04. Mai 2021 11:17

antiheld2000
kennt CMS/ms
Registriert: 21. Dezember 2010
Beiträge: 128

Module Update unmöglich: Grundversion von cmsms muss aktualisiert …

Moin,

ich versuche gerade diverse vernachlässigte Module zu aktualisieren. Leider wird mir dies jedoch mit folgender Meldung verwehrt: Die Grundversion von CMS Made Simple muss aktualisiert werden, bevor diese Aktion Erfolg haben kann

Installiert ist die aktuellste Version CMS Made Simple™ 2.2.15 “Bonaventure”.

Hat jemand eine Idee, wie ich trotzdem die Module updaten kann?

Mit Dank und Gruß

Offline

#2 04. Mai 2021 19:30

NaN
Moderator
Ort: Halle (Saale)
Registriert: 09. November 2010
Beiträge: 4.383

Re: Module Update unmöglich: Grundversion von cmsms muss aktualisiert …

Um welche Module und welche Versionen geht es?

Wenn ich das im Code jetzt richtig sehe, dann kommt dieser Fehler nur dann, wenn das Datenbankschema, das in der DB gespeichert wurde, nicht mit dem der aktuellen CMS-Version übereinstimmt.
Laut /lib/version.php müsste es 202 sein.
Was steht bei Dir da in der DB? (Da gibt es eine Tabelle [db_präfix]_version)

Möglicherweise ist das letzte CMS Update nicht fehlerfrei bis zum Ende durchgelaufen.


Module: GBFilePicker, AdvancedContent
Sicherheit: Beispiel .htaccess-Datei
CMSms 1.12.2 unter PHP 7:
cmsms-1.12.2-php7.2-diff.tar.gz (nur die geänderten Dateien)
cmsms-1.12.3.zip (inoffiziell - komplett inkl. Installer)

Offline

#3 06. Mai 2021 16:32

Janl
Server-Pate
Ort: Freistadt, Österreich
Registriert: 13. Dezember 2010
Beiträge: 1.210
Webseite

Re: Module Update unmöglich: Grundversion von cmsms muss aktualisiert …

Es gibt Module die nicht funktionieren mit der letzten Version CMSMS.
Schicke bitte eine Liste Deiner Mudule.

MfG
Jan


Ubuntu 16.04 KDE - Kubuntu 18.04 / win10 (1 duo-boot laptop)- LAMP
Raspi 4b mit Ubuntu 20.04 (64bit) und Mate.

Offline