Du bist nicht angemeldet. Der Zugriff auf einige Boards wurde daher deaktiviert.

#1 26. Juni 2020 00:24

rx9
hat von CMS/ms gehört
Registriert: 17. Juni 2017
Beiträge: 6

Cataloger erstellt keine Thumbnails

Hallo zusammen,

ich versuche seit Stunden das Cataloger-Modul zum laufen zu bekommen.Bilder können hochgeladen werden, aber die Thumbnail-Erstellung scheitert.

  • Imagemagick ist installiert (für php7.2 stable)

  • cmsms läuft in version 2.2.14

  • Es gibt keine PHP Error

  • Keine Fehlermeldung im cmsms log

  • Cataloger läuft in Version 1.0.2

  • Upload Pfade sind korrekt

  • Berechtigungen auf Uploadverzeichnissen ist 777

  • Speicherplatz ist genügend vorhanden.

Das Originalbild wird hochgeladen, das in Cataloger festgelegte Verzeichnis für Thumbnails bleibt aber leer.

Neben dem Upload-Picker müsste eigentlich schon das Thumbnail für hochgeladene Bilder angezeigt werden. Hier zeigt der Browser allerdings schon ein fehlendes Bild an. (siehe Anhang)
Die Bildadresse lautet https://***.de/admin/moduleinterface.php?mact=Cataloger,m1_,image,0&__c=c46cafac0d0e4a236c4&i=internet_1_it_1_125_1.jpg&ac=582 Rufe ich diese Manuell auf, bekomme ich einen http Error 500.

Ich bin nach stundenlanger Fehlersuche mit meinem Latein am Ende. Hat jemand schon mal ähnliche Probleme gehabt oder eine Idee woran es liegen kann?

Besten Dank und liebe Grüße

Offline

#2 27. Juni 2020 12:45

NaN
Moderator
Ort: Halle (Saale)
Registriert: 09. November 2010
Beiträge: 4.329

Re: Cataloger erstellt keine Thumbnails

Wenn möglich, schau mal in die Error-Logs auf dem Server.
(frag zur Not Deinen Provider wo die liegen)
Ein pauschaler 500er ist immer schwierig zu debuggen.
Aber ich vermute, dass der 500er nicht das Problem sein wird.
Das passiert vermutlich, weil das Bild nicht existiert.
Die Frage, warum es nicht existiert, werden wir damit kaum klären können.
Aber vielleicht steht in den Logs ja noch mehr drin, was beim Erstellen der Bilder schief gelaufen sein könnte.

Offline

#3 30. Juni 2020 17:59

rx9
hat von CMS/ms gehört
Registriert: 17. Juni 2017
Beiträge: 6

Re: Cataloger erstellt keine Thumbnails

Hallo NaN, danke für die schnelle Antwort,

ich werde bei beim Provider nach den logs nachfragen und hoffe das hilft.
Hier noch mal meine Syteminformationen:


----------------------------------------------

Cms Version: 2.2.14

Installed Modules:

    AceEditor2: 1.05
    AdminSearch: 1.0.5
    AdvancedContent: 0.9.4.3
    CGCalendar: 2.6.2
    CGExtensions: 1.65.2
    CGSimpleSmarty: 2.2.1
    CGUserDirectory: 1.5.1
    CMSContentManager: 1.1.9
    CMSMailer: 6.2.14
    Captcha: 1.0
    Cataloger: 1.0.2
    CmsJobManager: 0.1.3
    ContentAliases: 2.0
    CustomContent: 1.10
    DesignManager: 1.1.8
    FileManager: 1.6.11
    FilePicker: 1.0.4.1
    FormBuilder: 1.0.2
    FrontEndUsers: 3.2.2
    Gallery: 2.4.2
    JQueryTools: 1.4.2
    MenuManager: 1.50.3
    MicroTiny: 2.2.4
    ModuleManager: 2.1.7
    Navigator: 1.0.9
    News: 2.51.10
    Search: 1.51.8
    SelfRegistration: 1.14.6
    ThemeManager: 1.1.8


Config Information:

    php_memory_limit:
    max_upload_size: 10000000
    url_rewriting: none
    page_extension:
    query_var: bereich
    auto_alias_content: true
    locale: de_DE.UTF8
    set_names: true
    timezone: Europe/Berlin
    permissive_smarty: false


Php Information:

    phpversion: 7.2.19
    md5_function: An (Ja)
    json_function: An (Ja)
    gd_version: 2
    tempnam_function: An (Ja)
    magic_quotes_runtime: Aus (Nein)
    E_ALL: 32759
    E_STRICT: 2048
    E_DEPRECATED: 8192
    test_file_timedifference: No time difference found
    test_db_timedifference: No time difference found
    create_dir_and_file: 1
    memory_limit: 100M
    max_execution_time: 180
    register_globals: Aus (Nein)
    output_buffering: Aus (Nein)
    disable_functions:
    open_basedir:
    test_remote_url: Erfolgreich abgeschlossen
    file_uploads: An (Ja)
    post_max_size: 8M
    upload_max_filesize: 10M
    session_save_path: /tmp (1773)
    session_use_cookies: An (Ja)
    xml_function: An (Ja)
    xmlreader_class: An (Ja)
    check_ini_set: An (Ja)
    curl: An


Performance Information:

    allow_browser_cache: An (Ja)
    browser_cache_expiry: 9000
    php_opcache: Aus (Nein)
    smarty_cache: An (Ja)
    smarty_compilecheck: An (Ja)
    auto_clear_cache_age: An (Ja)

Server Information:

    Server Software: Apache/2.4.41
    Server Api: cgi-fcgi
    Server Os: Linux 3.18.114-pvops-xen-x64 An x86_64
    Server Db Type: MySQL (mysqli)
    Server Db Version: 5.6.19
    Server Db Grants: Es konnte keine „GRANT ALL“-Berechtigung gefunden werden. Dies kann bedeuten, dass Sie bei der Installation oder beim Entfernen von Modulen, oder sogar beim Hinzufügen und Löschen von Elementen, einschließlich Seiten, Probleme haben könnten.


Permission Information:

    tmp: /kunden/186958_35719/webseiten/***/tmp (0777)
    tmp_cache: /kunden/186958_35719/webseiten/***/tmp/cache (0777)
    templates_c: /kunden/186958_35719/webseiten/***/tmp/templates_c (0710)
    modules: /kunden/186958_35719/webseiten/***/modules (0755)
    uploads: /kunden/186958_35719/webseiten/***/uploads (0777)
    Maske zum Erstellen von Dateien (umask): /kunden/186958_35719/webseiten/***/tmp/cache (0777)
    config_file: 0444

----------------------------------------------

Offline