Du bist nicht angemeldet. Der Zugriff auf einige Boards wurde daher deaktiviert.

#1 08. Mai 2019 16:43

philfr
probiert CMS/ms aus
Registriert: 08. Mai 2019
Beiträge: 28

Installationsproblem bei 1blu

Hallo,

ich habe eine 1blu-Homepage (Linux). Dort gibt es die 1blu-easyApp "CMS made simple", die ich versucht habe zu installieren (inklusive Beispielseiten). Es handelt sich um Version 2.2.10. Als Installationsverzeichnis habe ich das www-Unterverzeichnis /test angegeben.
Bei der Installation passiert folgendes:

  • DB wird installiert

  • Es wird die Datei /test/config.php angelegt

  • Es wird eine erfolgreiche Installation gemeldet

Das ist etwas wenig für ein CMS, vermutlich ist das Installationspaket defekt?

Hat jemand einen Tipp für mich?

Viele Grüße
Frank

Offline

#2 08. Mai 2019 18:27

Janl
Server-Pate
Ort: Freistadt, Österreich
Registriert: 13. Dezember 2010
Beiträge: 1.146
Webseite

Re: Installationsproblem bei 1blu

Besser nachfragen bei 1blu, ich weiss nicht wie die das eingerichtet haben.

Wenn Du Zugang hast zum Webspace und Phar ist installiert kannst Du auch selber installieren.

MfG
Jan


Ubuntu 16.04 mit KDE - Kubuntu 18.04 / win10 (1 duo-boot laptop)- LAMP

Offline

#3 09. Mai 2019 07:49

philfr
probiert CMS/ms aus
Registriert: 08. Mai 2019
Beiträge: 28

Re: Installationsproblem bei 1blu

Bei der eigenen Installation bin ich nun bis zum Schritt 7 gekommen, da sagt er:

Sorry, something has gone wrong... (internal error) (705)

Offline

#4 09. Mai 2019 21:20

NaN
Moderator
Ort: Halle (Saale)
Registriert: 09. November 2010
Beiträge: 4.256

Re: Installationsproblem bei 1blu

Beim Start von Schritt 7 oder erst nach Schritt 7?

Wenn ersteres, sieht es nach einem Session-Problem aus. (abgelaufen oder so)
D.h. der Installer weiß bei Schritt 7 plötzlich nicht mehr, ob er upgraden, reparieren oder neu installieren soll.

Wenn letzteres, sind wir eigentlich schon bei Schritt 8.
Da kann es zusätzlich zum Session-Problem auch sein, dass nicht alle Dateien fehlerfrei entpackt werden konnten. Schreibberechtigungen o.ä.
Denn es wird nach einer Datei namens "schema.php" gesucht.
Ist die nicht zu finden -> Fehler.
Die Frage ist, warum sie nicht gefunden werden kann.

Mehr kann ich dazu leider auch erstmal nicht sagen.

Offline

#5 10. Mai 2019 06:00

philfr
probiert CMS/ms aus
Registriert: 08. Mai 2019
Beiträge: 28

Re: Installationsproblem bei 1blu

Sorry, Schritt 7 war schon grün markiert, also ist es bei Schritt 8 passiert.
Eine Datei schema.pdf gibt es nicht.
Ist die nur temporär da?
Weil auf meinem lokalen Rechner lief die Installation durch, dort gibt es die Datei aber auch nicht.

Offline

#6 10. Mai 2019 11:37

philfr
probiert CMS/ms aus
Registriert: 08. Mai 2019
Beiträge: 28

Re: Installationsproblem bei 1blu

Nachdem weder die 1blu "easyApp" noch die phar-Installationsdatei auf dem Webserver funktionierten, habe ich es mit der expanded-Version 2.2.10 versucht, und die ist nun durchgelaufen :-)

Falls hier ein Entwickler mitliest:
Den Installationsfehler 705 gibt es im Quelltext 3x (1x class.wizard_step7.php und 2x class.wizard_step8.php)
Da könnte man auch 3 verschiedene Codes verwenden

Gruß
Frank

Offline

#7 10. Mai 2019 12:23

NaN
Moderator
Ort: Halle (Saale)
Registriert: 09. November 2010
Beiträge: 4.256

Re: Installationsproblem bei 1blu

Den Installationsfehler 705 gibt es im Quelltext 3x

Daher weiß ich ja, dass es entweder an der Session oder am Entpacken der Dateien lag wink
Zumindest für die Sache mit der Datei sollte man einen anderen Code verwenden.
Die anderen beiden Stellen sind ja dasselbe Problem.

Aber schön, dass es funktioniert. Die expanded Version hätte ich als nächstes vorgeschlagen.

Eine Datei schema.pdf gibt es nicht.

php wink

Ist die nur temporär da?

Ja.
Das Install-Verzeichnis wird zur Laufzeit in ein temporäres Verzeichnis entpackt. (variiert je nach Umgebung) Und danach wird alles wieder gelöscht.
Falls beim Entpacken etwas schiefgeht - was auch immer in Deinem Fall das Problem war - dann bleibt eigentlich nur die expanded Version. Da ist dieses Install-Verzeichnis bereits entpackt und kann direkt im Verzeichnis des Webspace ausgeführt werden.

Diese ganze Phar-Geschichte ist von so vielen Faktoren abhängig, auf die man auf einem Shared Webspace überhaupt keinen Einfluss hat. Aber da redet man bei den Entwicklern gegen die Wand. Auch die Tatsache, dass beim Installieren nicht geprüft wird, ob die zu entpackende Datei auch wirklich fehlerfrei entpackt werden konnte, nein, noch schlimmer, dass man da mit dem Silentoperator (@) jegliche Fehlermeldung unterdrückt, ist da echt nicht wirklich hilfreich.

Offline