Du bist nicht angemeldet. Der Zugriff auf einige Boards wurde daher deaktiviert.

#1 28. März 2019 20:57

dlen
probiert CMS/ms aus
Registriert: 05. Februar 2011
Beiträge: 55

http error 500 bei Version 2.1.5 und php-Version 5.6.4

Liebe Foristen,

seit einiger Zeit ist die Website roswitha-jacobi.de offline mit "http error 500 (internal server error).

phpinfo() liefert aber eine richtige Anzeige, php funktioniert also im Prinzip, nur eben cmsms nicht mehr.
Der Fehler trat "spontan" auf, d.h. ohne Eingreifen meinerseits.
Leider kommt bei der Adminseite erwartungsgemäß derselbe Fehler.

Ich konnte alle Dateien auf Viren prüfen über ein serverseitiges Tool namens ImmunifyAV, das hat nichts gefunden.

Wo könnte ich noch gucken? Wie könnte ich da weiter kommen?
Bin für jede fundierte Anregung dankbar.

Dominik

Offline

#2 28. März 2019 21:02

NaN
Moderator
Ort: Halle (Saale)
Registriert: 09. November 2010
Beiträge: 4.235

Re: http error 500 bei Version 2.1.5 und php-Version 5.6.4

phpinfo() liefert aber eine richtige Anzeige

Definiere "richtig".
PHP 5.6?

Der Fehler trat "spontan" auf, d.h. ohne Eingreifen meinerseits.

Ich tippe mal darauf, dass Dein Provider etwas geändert hat.
Z.B. Die PHP-Version.
Oder die Apache-Version?

Benenne doch mal - falls vorhanden - die .htaccess Datei um. Evtl. steht dort etwas drin, was jetzt nicht mehr geht. Könnte z.B. dieses Problem hier sein:
https://www.cms-1.org/forum/viewtopic.p … 997#p37997

Offline

#3 29. März 2019 23:13

dlen
probiert CMS/ms aus
Registriert: 05. Februar 2011
Beiträge: 55

Re: http error 500 bei Version 2.1.5 und php-Version 5.6.4

Danke für die Anregungen.
mit "richtigem" phpinfo-Output meine ich, dass der Browser eine lange, wohlformatierte Liste von sehr vielen Parametern ausgibt, die leider nicht die Webserver-Engine preisgibt. Was immerhin zeigt, dass php teilweise funktioniert.
Schreibe ich jedoch Folgendes in eine Datei, die hochlade und dann ausgeben lasse:

<?php 
$version = apache_get_version(); 
echo "$version\n";
?>

so erhalte ich wieder den bekannten "http error 500" - Fehler.
Das Rootverzeichnis hat keine .htaccess.
Es gibt 6 oder 7 .htaccess im Verzeichnisbaum, von denen einige nur auskommentierten Inhalte haben, andere hingegen diesen:

<Files ~ "\.(php|php3|php4|php5|phtml|pl|cgi|txt|pdf)$">
   	   order deny,allow
   	   deny from all
</Files>

Ich habe testweise den Mittelteil wie in Deinem Link angeregt ersetzt durch
Require all denied
aber es hat nichts genützt.
Des weiteren habe ich versucht, die Webserverversion herauszubekommen per (über php-Datei)

 if(isset($_SERVER['SERVER_SOFTWARE'])){
      echo $_SERVER['SERVER_SOFTWARE'];

Die lakonische Antwort war "Apache".
Dann habe ich über telnet eine Antwort eingefordert. Die war "nginx".
D.h. manches php wird korrekt verarbeitet, anderes hingegen löst den 500er-Fehler aus.
Vertrackt.

Offline

#4 29. März 2019 19:49

Janl
Server-Pate
Ort: Freistadt, Österreich
Registriert: 13. Dezember 2010
Beiträge: 1.132
Webseite

Re: http error 500 bei Version 2.1.5 und php-Version 5.6.4

Wenn Du schon auf Version 2 bist, dann ist eine neuere PHP-Version wahrscheinlich besser.

Als Webserver wird nur Nginx angegeben, kannst Du umstellen auf Apache?

MfG
Jan


Ubuntu 16.04 mit KDE - Kubuntu 18.04 / win10 (1 duo-boot laptop)- LAMP

Offline

#5 29. März 2019 22:56

dlen
probiert CMS/ms aus
Registriert: 05. Februar 2011
Beiträge: 55

Re: http error 500 bei Version 2.1.5 und php-Version 5.6.4

Thx.
Nein, ich kann nicht auf Apache umstellen. Billiger shared hosting Provider (cghost), der im Moment dazu unerreichbar zu sein scheint (seufz, you get what you pay for - aber ich hatte kürzlich den Fall, dass auch webgo, die ja nun sowas wie renommiert sind, eine Website inklusive Emails irrtümlich komplett gelöscht hat, nicht wiederherstellbar. Sowas gibt's also auch.)

Habe inzwischen den error log inspiziert und er ist voll mit folgender Meldung:

Got error 'PHP message: PHP Fatal error:  Class 'PHPMailer' not found in /var/www/vhosts/roswitha-jacobi.de/httpdocs/lib/classes/class.cms_mailer.php on line 62\n'

Die Zeilen 59-62 sehen dann so aus:

    $dir = dirname(__DIR__).'/phpmailer/';
    require_once($dir.'/PHPMailerAutoload.php');

    $this->_mailer = new PHPMailer($exceptions);

Die Datei PHPMailerAutoload.php ist am korrekten Ort, soll wohl die Klasse PHPMailer zur Verfügung stellen, vermute ich, was aber nicht stattfindet.

Klingelt da bei jemandem was?

Vermute dass der Provider entweder die Webserverversion geändert hat oder irgendeinen Serverparameter.

Offline

#6 30. März 2019 23:58

Janl
Server-Pate
Ort: Freistadt, Österreich
Registriert: 13. Dezember 2010
Beiträge: 1.132
Webseite

Re: http error 500 bei Version 2.1.5 und php-Version 5.6.4

Alle Caches inkl. Browsercache schon geleert?
Filepermissions kontrolliert?

Ich nehme an dass keine SSH-Zugang da ist.
Bei PHPinfo sehe ich Plesk, hast Du die Zugang?
Wenn, dann in Plesk PHP-settings kontrollieren.

Wenn das neu installiert ist versuche dann evt. mal mit neu hochladen.


MfG
Jan

Beitrag geändert von Janl (30. März 2019 00:09)


Ubuntu 16.04 mit KDE - Kubuntu 18.04 / win10 (1 duo-boot laptop)- LAMP

Offline

#7 30. März 2019 13:23

NaN
Moderator
Ort: Halle (Saale)
Registriert: 09. November 2010
Beiträge: 4.235

Re: http error 500 bei Version 2.1.5 und php-Version 5.6.4

Filepermissions kontrolliert?

Wäre auch meine Vermutung.
Gehe mal alle Verzeichnisse durch und sorge dafür, dass alle Verzeichnisse/Dateien wenigstens von jedem lesbar sind. (Schreibrechte braucht man eigentlich nur im uploads und im tmp Verzeichnis - kann aber sein, dass Dein Server für alle anderen auch noch Rechte zum Ausführen benötigt)
Denn das Problem liegt nicht daran, dass die Datei "PHPMailerAutoload.php" nicht gefunden werden kann, sonden daran, dass die Autoloadfunktion in dieser Datei offenbar die Datei für die Klasse PHPMailer "class.phpmailer.php" nicht laden kann. Denn die Datei wird nur geladen, wenn sie lesbar ist. Anderenfalls meldet sich PHP mit der Meldung "Fatal Error...". Es wird ja bemängelt, dass die Klasse nicht da ist, nicht, dass die Datei fehlt.

Offline

#8 01. April 2019 22:19

dlen
probiert CMS/ms aus
Registriert: 05. Februar 2011
Beiträge: 55

Re: http error 500 bei Version 2.1.5 und php-Version 5.6.4

Hi, Thx,
alle Verzeichnisse haben rwxr-xr-x und alle php-Dateien haben rw--r--r. Ich glaube nicht, dass sich da spontan was geändert hat.
Interessanterweise bekommt man mit dem folgenden php auch einen http error 500:

<?php
  $version = apache_get_version();
  echo "$version\n";
?>

Der Kollege auf https://forum.cmsmadesimple.org meint, es könne an einem Virenscanner oder modsecurity liegen. Dies kann ich jedoch ohne jeden Serverzugang nicht testen, oder?

Beitrag geändert von dlen (01. April 2019 22:21)

Offline

#9 01. April 2019 22:53

Janl
Server-Pate
Ort: Freistadt, Österreich
Registriert: 13. Dezember 2010
Beiträge: 1.132
Webseite

Re: http error 500 bei Version 2.1.5 und php-Version 5.6.4

Hast Du Zugang zu Plesk?


Ubuntu 16.04 mit KDE - Kubuntu 18.04 / win10 (1 duo-boot laptop)- LAMP

Offline

#10 01. April 2019 01:03

NaN
Moderator
Ort: Halle (Saale)
Registriert: 09. November 2010
Beiträge: 4.235

Re: http error 500 bei Version 2.1.5 und php-Version 5.6.4

Interessanterweise bekommt man mit dem folgenden php auch einen http error 500:

Ich vermute mal, es wurden aus Sicherheitsgründen bestimmte Funktionen deaktiviert. Wenn man die dann in einem Script ausführt, kann es zu einem solchen Fehler kommen.
Bzw. kann man seinen Server ja generel so einrichten, dass er bei jedem x-beliebigen Fehler gleich einen 500er auswirft. Das macht man häufig, um so wenig wie möglich Infos nach außen zu geben.

Wenn Du apache_get_version(); mal in einem UDT im Backend vom CMS ausführen lässt, könntest Du eventuell die korrekte Fehlermeldung herausbekommen.

mod_security sollte Dir eigentlich bei phpinfo() angezeigt werden.

Offline

#11 01. April 2019 12:58

dlen
probiert CMS/ms aus
Registriert: 05. Februar 2011
Beiträge: 55

Re: http error 500 bei Version 2.1.5 und php-Version 5.6.4

@janl: Ja, Plesk läuft, aber ich kann dort nichts einstellen.
@NaN: Backend schmeißt denselben Fehler, geht also nicht. phpinfo sagt nichts über ein mod_*.

Ich fürchte, das führt hier nicht weiter.

Wir werden eine statische Seite mit einem redirect reinsetzen und die Site komplett umziehen, wenn wir vom Provider keinen Auth-Code kriegen (er stellt sich anscheinend tot) dann eben mit neuem Domainnamen.

Vielen vielen Dank auf jeden Fall für die Zeit.

Beitrag geändert von dlen (01. April 2019 12:59)

Offline

#12 01. April 2019 17:55

Janl
Server-Pate
Ort: Freistadt, Österreich
Registriert: 13. Dezember 2010
Beiträge: 1.132
Webseite

Re: http error 500 bei Version 2.1.5 und php-Version 5.6.4

Wenn Deine Domain  roswitha-jacobi.de auf Deine Name läuft dann kannst Du bei Denic eine Änderung von Hoster beauftragen, ein Hoster kann das nicht stoppen.

Schau mal bei Netcup.de oder nimm Kontakt auf mit mir, momentan betreue ich 7 Server da gibts sicher ein Stelle für Deine Webseite und CMSMS Kenntnisse sind vor Handen ;-)

MfG
Jan


Ubuntu 16.04 mit KDE - Kubuntu 18.04 / win10 (1 duo-boot laptop)- LAMP

Offline

#13 03. April 2019 10:17

dlen
probiert CMS/ms aus
Registriert: 05. Februar 2011
Beiträge: 55

Re: http error 500 bei Version 2.1.5 und php-Version 5.6.4

Habe alle nach netcup umgezogen. Dann der Schreck: genau dasselbe Problem - es war also ein Fehler innerhalb von CMSMS.
Dann habe ich alle Dateien gelöscht, bis auf das uploads/ Verzeichnis wo die Bilder drin sind, eine komplett neue CMSMS-Installation durchgeführt mit der richtigen Version, die Datenbank wieder eingespielt und eine Reihe von Hacks, die ich mit dem Gallerymodul gemacht hatte, wieder zum Laufen gebracht - das hat geholfen.
Schließlich konnte ich diese nun bei netcup funktionierende Site wieder bei cghost zum Laufen bringen - es lag also nicht an irgendwelchen Serverparametern, oder Antivirus oder ähnlichem, sondern daran, dass php-Dateien im CMS verändert worden waren. Welche, lässt sich nicht mehr nachvollziehen. Und wie und warum auch nicht. Könnte ein missglückter Hack gewesen sein. Irgendwann zwischendrin sah ich im Browser einen großen CSS-Eintrag, in dem eine Menge komischer Werbe-URLs vorkamen. Der ist dann verschwunden.
Alles sehr seltsam.
Aber nochmals Danke für die Hilfestellungen.

Offline

#14 04. April 2019 16:05

NaN
Moderator
Ort: Halle (Saale)
Registriert: 09. November 2010
Beiträge: 4.235

Re: http error 500 bei Version 2.1.5 und php-Version 5.6.4

Hm, ärgerlich, das auf diese Weise erfahren zu müssen.
Da hätten wir uns dumm und dämlich rätseln können.
Mich würde interessieren, inwieweit Du die Sicherheitstipps umgesetzt hattest.

Offline