Du bist nicht angemeldet. Der Zugriff auf einige Boards wurde daher deaktiviert.

#1 11. Februar 2019 21:41

ampelmann
probiert CMS/ms aus
Registriert: 24. Januar 2012
Beiträge: 35

PHP 7 und Smarty

Liebe Experten,

nun hat der Provider auf PHP 7 umgestellt und ich bekomme mit CMSMS 1.12.1 auf den Seiten mit erweitertem Inhalt eine Fehlermeldung folgenden Inhalts. Nicht böse werden, ich kopiere mal die gesamte Meldung.

Habt Ihr eine Idee, was ich da tun könnte ohne das CMS zu updaten?

Fatal error: Uncaught Error: Function name must be a string in /homepages/43/d75740919/htdocs/content/lib/smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php:402 Stack trace: #0 /homepages/43/d75740919/htdocs/content/lib/smarty/libs/sysplugins/smarty_internal_templateparser.php(2388): Smarty_Internal_TemplateCompilerBase->compileTag('content', Array) #1 /homepages/43/d75740919/htdocs/content/lib/smarty/libs/sysplugins/smarty_internal_templateparser.php(3093): Smarty_Internal_Templateparser->yy_r38() #2 /homepages/43/d75740919/htdocs/content/lib/smarty/libs/sysplugins/smarty_internal_templateparser.php(3191): Smarty_Internal_Templateparser->yy_reduce(38) #3 /homepages/43/d75740919/htdocs/content/lib/smarty/libs/sysplugins/smarty_internal_smartytemplatecompiler.php(111): Smarty_Internal_Templateparser->doParse(3, '}') #4 /homepages/43/d75740919/htdocs/content/lib/smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php(273): Smarty_Internal_SmartyTemplateCompiler->doCompile('{process_pageda...') #5 /homep in /homepages/43/d75740919/htdocs/content/lib/smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php on line 402

Vielen Dank und beste Grüße,
Maik

Offline

#2 11. Februar 2019 21:54

cyberman
Moderator
Ort: Dohna / SN / Deutschland
Registriert: 13. September 2010
Beiträge: 6.934

Re: PHP 7 und Smarty

Ganz ohne Update wird es nicht gehen. Zumindest musst du ein paar Dateien aktualisieren.

NaN hat dafür mal ein kleines Päckchen geschnürt

CMSms 1.12.2 unter PHP 7.2: cmsms-1.12.2-php7.2-diff.tar.gz

Offline

#3 11. Februar 2019 22:17

ampelmann
probiert CMS/ms aus
Registriert: 24. Januar 2012
Beiträge: 35

Re: PHP 7 und Smarty

cyberman schrieb:

Ganz ohne Update wird es nicht gehen. Zumindest musst du ein paar Dateien aktualisieren.

NaN hat dafür mal ein kleines Päckchen geschnürt

CMSms 1.12.2 unter PHP 7.2: cmsms-1.12.2-php7.2-diff.tar.gz

Na, das ging ja schnell. Danke Dir.
Ich habe in der Zwischenzeit Euren Thread gefunden und die Zeile 402 mit dem Funktionsaufruf geändert:

return $this->smarty->registered_plugins[$plugin_type][$tag][0][0]->{$function[1]}($new_args, $this);


Und siehe, es läuft erstmal.

Dankeschön.
Maik

Offline

#4 12. Februar 2019 21:54

cyberman
Moderator
Ort: Dohna / SN / Deutschland
Registriert: 13. September 2010
Beiträge: 6.934

Offline

#5 12. Februar 2019 21:57

cyberman
Moderator
Ort: Dohna / SN / Deutschland
Registriert: 13. September 2010
Beiträge: 6.934

Re: PHP 7 und Smarty

Vorbeugen ist besser als nach hinten zu fallen - von daher kann ich dir das Update Paket nur ans Herz legen. Weil dein Fehler nicht der einzige ist, der unter PHP 7 Probleme macht.

Bringt dir ja auch nix, wenn es dir sinnlos das Error Log zumüllt, nur, weil die Fehlermeldungen unterdrückt sind...

Offline

#6 13. Februar 2019 07:29

ampelmann
probiert CMS/ms aus
Registriert: 24. Januar 2012
Beiträge: 35

Re: PHP 7 und Smarty

Wird das Update auch mit 1.12.1 funktionieren?

Offline

#7 14. Februar 2019 10:32

cyberman
Moderator
Ort: Dohna / SN / Deutschland
Registriert: 13. September 2010
Beiträge: 6.934

Re: PHP 7 und Smarty

Die Änderungen von der 1.12.1 zur 1.12.2 waren relativ gering. Und die Anpassungen des PHP7-Pakets betreffen im wesentlichen externe Komponenten.

Sollte daher grundsätzlich funktionieren. Jedoch trotzdem das Netz und den doppelten Boden nicht vergessen, sprich Backup, Backup, Backup cool

Offline

#8 14. Februar 2019 10:38

cyberman
Moderator
Ort: Dohna / SN / Deutschland
Registriert: 13. September 2010
Beiträge: 6.934

Re: PHP 7 und Smarty

cyberman schrieb:

Die Änderungen von der 1.12.1 zur 1.12.2 waren relativ gering.

Ist zudem ein reines File Update, ändert also nix an der Datenbank. Von daher solltest du die Chance nutzen, auf die aktuellste 1er zu aktualisieren wink .

Offline

#9 14. Februar 2019 19:55

ampelmann
probiert CMS/ms aus
Registriert: 24. Januar 2012
Beiträge: 35

Re: PHP 7 und Smarty

Top. Danke für die Hilfe.

Offline

#10 26. Februar 2019 09:28

brandy
Server-Pate
Registriert: 05. Juni 2011
Beiträge: 729
Webseite

Re: PHP 7 und Smarty

Hallo!

Ich probiere gerade CMSMS 1.12.2 auf einem Server mit PHP 7.1.26 zu installieren.
Bei Punkt 6 bleibt er mir aber immer beim Punkt "Import von Beispieldateien" stecken.

Was hats da? Muss ich sobald ich PHP 7 habe das Päckchen von NaN integrieren?

Vielen Dank!

Offline

#11 26. Februar 2019 14:20

cyberman
Moderator
Ort: Dohna / SN / Deutschland
Registriert: 13. September 2010
Beiträge: 6.934

Re: PHP 7 und Smarty

brandy schrieb:

Muss ich sobald ich PHP 7 habe das Päckchen von NaN integrieren?

Ja.

Bei Neuinstallationen bitte dies noch ändern

https://www.cms-1.org/forum/viewtopic.p … 364#p41364

Ist noch nicht in dem Paket drin!

Beitrag geändert von cyberman (26. Februar 2019 14:46)

Offline

#12 26. Februar 2019 16:05

bd0
Server-Pate
Ort: Köln
Registriert: 22. Juni 2011
Beiträge: 192

Re: PHP 7 und Smarty

Hallo allerseits,

habe letztens versucht eine relativ neue Installation von CmsMS 1.12.2 auf Php7.2.6 umzustellen und habe dafür das Paket von NaN drübergebügelt. Danach ging nix mehr. Whitescreen im Front- und Backend (wenn ich mich recht entsinne).
Habe dann die durch das "update" veränderten Ordner aus meinem Backup zurück gespielt und dann gings wieder. Ich habe dann die Änderungen an Smarty https://cms-1.org/forum/viewtopic.php?pid=41328#p41328   vorgenommen und auf Php7.2.6 umgestellt und seither läuft es soweit ich sehe problemlos.

Ich probiere es aber bei Gelegenheit nochmal mit einer sauberen 1.12.2 und dem update-packet von NaN.

dort installierte Module sind:
CMSMailer     5.2.14
FileManager     1.4.5
MenuManager     1.8.7
MicroTiny     1.2.9
ModuleManager     1.5.8

AceEditor     1.0    
AdvancedContent     0.9.4.3    
Captcha     1.0    
CGExtensions     1.53.19
CGSimpleSmarty     1.10    
CGSmartImage     1.20.5    
CMSDumper     1.3    
FormBuilder     0.8.1.6    
GBFilePicker     1.3.4    
JQueryTools     1.3.8    
LISE     1.3.1
MleCMS     1.11.4    
SimpleSiteInfo     3.3
ToolBox     1.3.11    
UsersGuide     2.0

Offline

#13 26. Februar 2019 16:31

cyberman
Moderator
Ort: Dohna / SN / Deutschland
Registriert: 13. September 2010
Beiträge: 6.934

Re: PHP 7 und Smarty

bd0 schrieb:

habe letztens versucht eine relativ neue Installation von CmsMS 1.12.2 auf Php7.2.6 umzustellen und habe dafür das Paket von NaN drübergebügelt. Danach ging nix mehr. Whitescreen im Front- und Backend (wenn ich mich recht entsinne).

Seltsam. Das Error Log wäre da schon mal interessant gewesen.

Hab gerade eben mit dem Original, dem Update Paket und der Änderung im Installationsassistenten eine neue Seite hochgezogen (PHP 7.2.15). Läuft im wesentlichen wie bekannt.

Bei einer weißen Seite hätte ich spontan auf eines der externen Module getippt. Wenn es da knallt, reisst es auch die komplette Seite runter.

Offline

#14 26. Februar 2019 16:35

cyberman
Moderator
Ort: Dohna / SN / Deutschland
Registriert: 13. September 2010
Beiträge: 6.934

Re: PHP 7 und Smarty

bd0 schrieb:

AdvancedContent     0.9.4.3    
...   
GBFilePicker     1.3.4

Zumindest hier hätte ich sofort eine Änderung anzubieten

https://www.cms-1.org/forum/viewtopic.p … 303#p38303

Offline

#15 26. Februar 2019 16:47

bd0
Server-Pate
Ort: Köln
Registriert: 22. Juni 2011
Beiträge: 192

Re: PHP 7 und Smarty

Sorry, Error Log kann ich leider nicht bieten, da ich gleich zurückgebaut habe. hmm
Danke für obigen Link, den Speicher ich mal in die Bookmarks!

Offline

#16 26. Februar 2019 21:07

brandy
Server-Pate
Registriert: 05. Juni 2011
Beiträge: 729
Webseite

Re: PHP 7 und Smarty

@cyberman: Danke, mit den beiden Änderungen funktioniert alles!

Vielen Dank!

Offline

#17 27. Februar 2019 08:23

brandy
Server-Pate
Registriert: 05. Juni 2011
Beiträge: 729
Webseite

Re: PHP 7 und Smarty

Ich arbeite jetzt gerade meine Webseiten ab und stelle sie sukzessive auf PHP 7.1 um.
Kann es sein, dass CMSMS 1.12 auch ohne einspielen neuerer Dateien auskommt?

Ich hab nämlich umgestellt - Hoster meint, es kann bis zu acht Minuten dauern - Cache geleert, Zwischenspeicher gelöscht, aktualisiert, jedoch kein Fehler oder ähnlich.

Muss man die Änderungen nur bei 1.12.2 machen?

Beitrag geändert von brandy (27. Februar 2019 08:24)

Offline

#18 27. Februar 2019 08:52

cyberman
Moderator
Ort: Dohna / SN / Deutschland
Registriert: 13. September 2010
Beiträge: 6.934

Re: PHP 7 und Smarty

Es könnte theoretisch sein, wenn die Fehlermeldungen unterdrückt sind.

Praktisch würde ich es aber nicht darauf ankommen lassen. Auch die Behandlung von Fehlern kostet unnötig Performance.

Offline

#19 27. Februar 2019 08:54

cyberman
Moderator
Ort: Dohna / SN / Deutschland
Registriert: 13. September 2010
Beiträge: 6.934

Re: PHP 7 und Smarty

bd0 schrieb:

Sorry, Error Log kann ich leider nicht bieten, da ich gleich zurückgebaut habe. hmm

Ließe sich im Zweifel noch mal in einer Testumgebung provozieren  cool

Offline

#20 27. Februar 2019 08:55

brandy
Server-Pate
Registriert: 05. Juni 2011
Beiträge: 729
Webseite

Re: PHP 7 und Smarty

In diese Richtung hab ich nichts eingestellt, in der config finde ich dazu nichts. Auch die error_log ist leer.
Ich werde mal auf 1.12.2 updaten und schauen was passiert!

Vielen Dank!

Offline

#21 27. Februar 2019 09:03

cyberman
Moderator
Ort: Dohna / SN / Deutschland
Registriert: 13. September 2010
Beiträge: 6.934

Re: PHP 7 und Smarty

Kann unter Umständen eine Server Einstellung sein, die du nicht siehst...

Offline

#22 27. Februar 2019 13:32

NaN
Moderator
Ort: Halle (Saale)
Registriert: 09. November 2010
Beiträge: 4.213

Re: PHP 7 und Smarty

Muss man die Änderungen nur bei 1.12.2 machen?

Also logischerweise gilt das DIFF-Paket nur für 1.12.2.
Du kannst das also nicht einfach bei CMSms 1.12 anwenden.
Ob und inwiefern CMSms 1.12 schon von allein mit PHP 7 klarkommt, hab ich nicht getestet.
Ich muss auch ehrlich sagen, dass mich das nicht wirklich interessiert.
Denn ich konzentriere mich da lieber auf die letzte offiziell veröffentlichte CMSms Version aus der 1-er Reihe. Und das ist nunmal die 1.12.2.

Offline